<!DOCTYPE html>
<html lang="en-CA">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

<!--/ Open Graphite /-->
<meta property="og:locale" content="en_CA" />
<meta property="og:type" content="" />
<meta property="og:url" content="https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/" />
<meta property="og:title" content="" />
<meta property="og:description" content="You know we are in the time of the Apocalypse when Nova Scotia Power is promising not to turn off the lights (or the heat) if you don’t pay your  bill. Well, at least not for the next 90 days if you are a residential or small business customer. “We are in uncertain and unprecedented […]" />
<meta property="og:site_name" content="Halifax Examiner" />
<meta property="og:image" content="https://www.halifaxexaminer.ca/wp-content/uploads/2018/04/1-1.png" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="455" />

<meta itemprop="description" content="You know we are in the time of the Apocalypse when Nova Scotia Power is promising not to turn off the lights (or the heat) if you don’t pay your  bill. Well, at least not for the next 90 days if you are a residential or small business customer. “We are in uncertain and unprecedented […]" />
<meta itemprop="image" content="https://www.halifaxexaminer.ca/wp-content/uploads/2018/04/1-1.png" />

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/" />
<meta name="twitter:title" content="" />
<meta name="twitter:description" content="You know we are in the time of the Apocalypse when Nova Scotia Power is promising not to turn off the lights (or the heat) if you don’t pay your  bill. Well, at least not for the next 90 days if you are a residential or small business customer. “We are in uncertain and unprecedented […]" />
<meta name="twitter:image" content="https://www.halifaxexaminer.ca/wp-content/uploads/2018/04/1-1.png" />
<meta name="twitter:creator" content="Tim_Bousquet" />
<meta name="twitter:site" content="Halifax Examiner" />
<!--/ Open Graphite End /-->

<title>Nova Scotia Power won&#8217;t cut off your electricity, but we&#8217;re not seeing the big cuts in rates that Ontario is ordering</title>
<script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script><link rel='dns-prefetch' href='//cdn.datatables.net' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//ws.sharethis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Halifax Examiner &raquo; Feed" href="https://www.halifaxexaminer.ca/feed/" />
<link rel="alternate" type="application/rss+xml" title="Halifax Examiner &raquo; Comments Feed" href="https://www.halifaxexaminer.ca/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Halifax Examiner &raquo; Nova Scotia Power won&#8217;t cut off your electricity, but we&#8217;re not seeing the big cuts in rates that Ontario is ordering Comments Feed" href="https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/feed/" />
<link rel="canonical" href="https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.halifaxexaminer.ca\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" href="https://www.halifaxexaminer.ca/wp-content/cache/minify/aa925.css" media="all" />


<link rel='stylesheet' id='jquery-datatables-css'  href='https://cdn.datatables.net/1.10.16/css/jquery.dataTables.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-buttons-css'  href='https://cdn.datatables.net/buttons/1.4.2/css/buttons.dataTables.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-select-css'  href='https://cdn.datatables.net/select/1.2.3/css/select.dataTables.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedheader-css'  href='https://cdn.datatables.net/fixedheader/3.1.3/css/fixedHeader.dataTables.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedcolumns-css'  href='https://cdn.datatables.net/fixedcolumns/3.2.3/css/fixedColumns.dataTables.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-responsive-css'  href='https://cdn.datatables.net/responsive/2.2.0/css/responsive.dataTables.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel="stylesheet" href="https://www.halifaxexaminer.ca/wp-content/cache/minify/805ae.css" media="all" />


<link rel='stylesheet' id='pmpro_print-css'  href='https://www.halifaxexaminer.ca/wp-content/plugins/paid-memberships-pro/css/print.css?ver=2.2.6' type='text/css' media='print' />
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel="stylesheet" href="https://www.halifaxexaminer.ca/wp-content/cache/minify/32d59.css" media="all" />


<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.halifaxexaminer.ca/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel="stylesheet" href="https://www.halifaxexaminer.ca/wp-content/cache/minify/3d6f6.css" media="all" />

<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=2.0.0' type='text/css' media='all' />
<link rel="stylesheet" href="https://www.halifaxexaminer.ca/wp-content/cache/minify/e8195.css" media="all" />

<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script src="https://www.halifaxexaminer.ca/wp-content/cache/minify/df983.js"></script>


<script type='text/javascript' src='https://cdn.datatables.net/1.10.16/js/jquery.dataTables.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.datatables.net/buttons/1.4.2/js/dataTables.buttons.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.4.2/js/buttons.colVis.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.4.2/js/buttons.print.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.32/pdfmake.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.32/vfs_fonts.js?ver=5.3.2'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jszip/3.1.3/jszip.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.4.2/js/buttons.html5.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.datatables.net/select/1.2.3/js/dataTables.select.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.datatables.net/fixedheader/3.1.3/js/dataTables.fixedHeader.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.datatables.net/fixedcolumns/3.2.3/js/dataTables.fixedColumns.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.datatables.net/responsive/2.2.0/js/dataTables.responsive.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var igsv_plugin_vars = {"lang_dir":"https:\/\/www.halifaxexaminer.ca\/wp-content\/plugins\/inline-google-spreadsheet-viewer\/languages","datatables_classes":".igsv-table:not(.no-datatables)","datatables_defaults_object":{"dom":"TC<'clear'>lfrtip"}};
/* ]]> */
</script>
<script src="https://www.halifaxexaminer.ca/wp-content/cache/minify/8a919.js"></script>

<script type='text/javascript' src='//www.google.com/jsapi?ver=5.3.2'></script>
<script src="https://www.halifaxexaminer.ca/wp-content/cache/minify/6c516.js"></script>




<script type='text/javascript'>
/* <![CDATA[ */
var meteorslidessettings = {"meteorslideshowspeed":"2000","meteorslideshowduration":"5000","meteorslideshowheight":"400","meteorslideshowwidth":"600","meteorslideshowtransition":"fade"};
/* ]]> */
</script>
<script src="https://www.halifaxexaminer.ca/wp-content/cache/minify/68e39.js"></script>

<script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<link rel='https://api.w.org/' href='https://www.halifaxexaminer.ca/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.halifaxexaminer.ca/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://www.halifaxexaminer.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.halifaxexaminer.ca%2Fprovince-house%2Fnova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.halifaxexaminer.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.halifaxexaminer.ca%2Fprovince-house%2Fnova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style><link rel="pingback" href="https://www.halifaxexaminer.ca/xmlrpc.php" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-52079249-1', 'halifaxexaminer.ca');
  ga('send', 'pageview');

</script><style type="text/css">.site-title a { background: url(https://www.halifaxexaminer.ca/wp-content/uploads/2015/03/Halifax-Examiner-logo.jpg) no-repeat !important; }</style>
<style type="text/css">/* Mailchimp for WP - Checkbox Styles */
.mc4wp-checkbox-wp-registration-form {
  clear: both;
  display: block;
  position: static;
  width: auto; }
  .mc4wp-checkbox-wp-registration-form input {
    float: none;
    width: auto;
    position: static;
    margin: 0 6px 0 0;
    padding: 0;
    vertical-align: middle;
    display: inline-block !important;
    max-width: 21px;
    -webkit-appearance: checkbox; }
  .mc4wp-checkbox-wp-registration-form label {
    float: none;
    display: block;
    cursor: pointer;
    width: auto;
    position: static;
    margin: 0 0 16px 0; }
</style><link rel="icon" href="https://www.halifaxexaminer.ca/wp-content/uploads/2016/03/cropped-1.logo_-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.halifaxexaminer.ca/wp-content/uploads/2016/03/cropped-1.logo_-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.halifaxexaminer.ca/wp-content/uploads/2016/03/cropped-1.logo_-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.halifaxexaminer.ca/wp-content/uploads/2016/03/cropped-1.logo_-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/


#pmpro_account .pmpro_box {
    font-size: 20px;
}

.pmpro_actionlinks a {
    margin-right: .25em;
}

.pmpro_actionlinks a {
    margin-right: .5em;
}

.pmpro_actionlinks a:after {
	content: '|';
    margin-left: 1em;
    color: #000;
}

.pmpro_actionlinks a:last-of-type:after {
    content: '';
}

blockquote::before {
    display: none;
}

blockquote {
    color: #000;
}
		</style>
		</head>
<body data-rsssl=1 class="post-template-default single single-post postid-54644 single-format-standard pmpro-body-has-access custom-header header-image content-sidebar genesis-breadcrumbs-visible genesis-footer-widgets-visible metro-pro-yellow" itemscope itemtype="https://schema.org/WebPage"><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-categories" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-467"><a href="https://www.halifaxexaminer.ca/category/city-hall/" itemprop="url"><span itemprop="name">City Hall</span></a></li>
<li id="menu-item-532" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-532"><a href="https://www.halifaxexaminer.ca/category/province-house/" itemprop="url"><span itemprop="name">Province House</span></a></li>
<li id="menu-item-4881" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4881"><a href="https://www.halifaxexaminer.ca/category/education/" itemprop="url"><span itemprop="name">Education</span></a></li>
<li id="menu-item-468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-468"><a href="https://www.halifaxexaminer.ca/category/environment/" itemprop="url"><span itemprop="name">Environment</span></a></li>
<li id="menu-item-466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-466"><a href="https://www.halifaxexaminer.ca/category/investigation/" itemprop="url"><span itemprop="name">Investigation</span></a></li>
<li id="menu-item-578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-578"><a href="https://www.halifaxexaminer.ca/category/journalism/" itemprop="url"><span itemprop="name">Journalism</span></a></li>
<li id="menu-item-635" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-635"><a href="https://www.halifaxexaminer.ca/category/commentary/" itemprop="url"><span itemprop="name">Commentary</span></a></li>
<li id="menu-item-470" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470"><a href="https://twitter.com/Tim_Bousquet" itemprop="url"><span itemprop="name">@Tim_Bousquet</span></a></li>
<li id="menu-item-748" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-748"><a href="https://www.halifaxexaminer.ca/login/" itemprop="url"><span itemprop="name">Log In</span></a></li>
</ul></div></nav><div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://www.halifaxexaminer.ca/">Halifax Examiner</a></p><p class="site-description" itemprop="description">An independent, adversarial news site in Halifax, NS</p></div><div class="widget-area header-widget-area"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://www.halifaxexaminer.ca/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.halifaxexaminer.ca/?s={s}" itemprop="target"></form></div></section>
</div></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-navigation-1" class="menu genesis-nav-menu menu-primary"><li id="menu-item-464" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-464"><a href="https://www.halifaxexaminer.ca/" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-580"><a href="https://www.halifaxexaminer.ca/about/" itemprop="url"><span itemprop="name">About</span></a>
<ul class="sub-menu">
	<li id="menu-item-2506" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2506"><a href="https://www.halifaxexaminer.ca/about/termsandconditions/" itemprop="url"><span itemprop="name">Terms and Conditions</span></a></li>
	<li id="menu-item-2507" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2507"><a href="https://www.halifaxexaminer.ca/about/commenting-policy/" itemprop="url"><span itemprop="name">Commenting policy</span></a></li>
</ul>
</li>
<li id="menu-item-527" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-527"><a href="https://www.halifaxexaminer.ca/archives/" itemprop="url"><span itemprop="name">Archives</span></a></li>
<li id="menu-item-529" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-529"><a href="https://www.halifaxexaminer.ca/contact/" itemprop="url"><span itemprop="name">Contact us</span></a></li>
<li id="menu-item-54096" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54096"><a href="https://www.halifaxexaminer.ca/subscription-account/subscription-levels/" itemprop="url"><span itemprop="name">Subscribe to the Halifax Examiner</span></a></li>
<li id="menu-item-18195" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18195"><a href="https://www.halifaxexaminer.ca/subscription-account/" itemprop="url"><span itemprop="name">Manage your account</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.halifaxexaminer.ca/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://www.halifaxexaminer.ca/category/featured/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Featured</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> Nova Scotia Power won&#8217;t cut off your electricity, but we&#8217;re not seeing the big cuts in rates that Ontario is ordering</div><article class="post-54644 post type-post status-publish format-standard has-post-thumbnail category-featured category-news category-province-house pmpro-has-access entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Nova Scotia Power won&#8217;t cut off your electricity, but we&#8217;re not seeing the big cuts in rates that Ontario is ordering</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2020-03-25T07:33:14-03:00">March 25, 2020</time> By <a href="https://www.halifaxexaminer.ca/author/jennifer-henderson/" title="Posts by Jennifer Henderson" class="author url fn" rel="author">Jennifer Henderson</a> <span class="entry-comments-link"><a href="https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><!-- Simple Share Buttons Adder (7.6.21) simplesharebuttons.com --><div class="ssba-classic-2 ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:left"><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/&amp;text=Nova%20Scotia%20Power%20won%E2%80%99t%20cut%20off%20your%20electricity%2C%20but%20we%E2%80%99re%20not%20seeing%20the%20big%20cuts%20in%20rates%20that%20Ontario%20is%20ordering%20via%20%40tim_bousquet"  target=&quot;_blank&quot; ><img src="https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/buttons/simple/twitter.png" style="width: 32px;" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /><div title="Twitter" class="ssbp-text">Twitter</div></a><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/"  target="_blank" ><img src="https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/buttons/simple/facebook.png" style="width: 32px;" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /><div title="Facebook" class="ssbp-text">Facebook</div></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/"  target=&quot;_blank&quot; ><img src="https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/buttons/simple/linkedin.png" style="width: 32px;" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" /><div title="Linkedin" class="ssbp-text">Linkedin</div></a><a data-site="tumblr" class="ssba_tumblr_share" href="http://www.tumblr.com/share/link?url=https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/"  target=&quot;_blank&quot; ><img src="https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/buttons/simple/tumblr.png" style="width: 32px;" title="tumblr" class="ssba ssba-img" alt="Share on Tumblr" /><div title="Tumblr" class="ssbp-text">Tumblr</div></a><a data-site="email" class="ssba_email_share" href="mailto:?subject=Nova%20Scotia%20Power%20won%26#8217;t%20cut%20off%20your%20electricity,%20but%20we%26#8217;re%20not%20seeing%20the%20big%20cuts%20in%20rates%20that%20Ontario%20is%20ordering&#038;body=sent%20from%20Halifax%20Examiner%20|%20HalifaxExaminer.ca%20https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/"><img src="https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/buttons/simple/email.png" style="width: 32px;" title="Email" class="ssba ssba-img" alt="Email this to someone" /><div title="email" class="ssbp-text">email</div></a><br/><a href="https://simplesharebuttons.com" target="_blank" class="ssba-share-text">Share this story</a></div></div><div id="attachment_30056" style="width: 537px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-30056" class="size-full wp-image-30056" src="https://www.halifaxexaminer.ca/wp-content/uploads/2016/07/Screen-Shot-2017-06-01-at-10.21.05-PM-e1508148226637.png" alt="" width="527" height="400" /><p id="caption-attachment-30056" class="wp-caption-text">Tufts Cove Generating Plant. Photo: Halifax Examiner</p></div>
<p><em>The Halifax Examiner is providing all COVID-19 coverage for free.</em></p>
<p>You know we are in the time of the Apocalypse when Nova Scotia Power is promising not to turn off the lights (or the heat) if you don’t pay your  bill. Well, at least not for the next 90 days if you are a residential or small business customer.</p>
<p>“We are in uncertain and unprecedented times,” reads the news release issued by NS Power president and CEO Wayne O’Connor. “As the COVID-19 pandemic evolves each day, we’re evolving too… we know that this is a situation that will be ongoing for months, not days, and we’re committed to supporting you… And that means making changes in how we do business.”</p>
<p>“For at least the next 90 days, we will not be disconnecting customers for nonpayment,” the release goes on. “We’re also committed to being flexible, relaxing payment timelines, waiving penalties and fees on unpaid bills, and providing options for residential and small business customers. If you’re struggling to pay your bill, our Customer Care team is ready to listen and work with you, so you can stay as current as possible with your payments.”</p>
<p>NS Power made $138-million in profit for its shareholders last year. It can afford to relax the payment schedule. But while the company says it is ready to forgive, it’s definitely <i>not</i> prepared to forget what ratepayers will owe eventually.</p>
<p>“We also encourage those that can, to stay up to date with their payments,” reads the release. “Not only will this avoid building up a balance, but it will help us support those who are most in need of financial assistance.”</p>
<p>Nova Scotians pay among the highest power bills in the country and saw a 1.2% increase this January. It would be nice to see an even bigger break on an essential service in these times of trouble.</p>
<p>Brian Gifford is a member of the Affordable Energy Coalition, which has fought to bring down the price of electricity and advocated for low-income people who often must choose whether “to heat or eat.” Gifford says he is “personally impressed” with the decisions made by the company that also include temporarily suspending “collections calls” and a commitment to “pause future interest charges on late payments” for the next 90 days.</p>
<p>However, Gifford says the Affordable Energy Coalition “is monitoring what is happening in Ontario to see if there&#8217;s anything further we want to recommend to NS Power and/or the Nova Scotia Government. We have allies in Ontario who have sent us notices about how Ontario is helping low income and all Ontario electricity customers. Ontario Hydro has cut electricity rates temporarily.”</p>
<p>Yesterday afternoon — at almost the same hour NS Power was sending out its news release — Doug Ford’s government in Ontario was ordering a price cut on electricity for all Ontario consumers for the next six weeks. Unlike Nova Scotia where low rates are only in effect overnight, Ontario customers have a broader choice of when they can pay less for using electricity. It’s referred to as a time-of-use rate. Here’s what the Ontario government’s news release said:</p>
<blockquote><p>For a 45-day period, the government is working to suspend time-of-use electricity rates, holding electricity prices to the off-peak rate of 10.1 cents-per-kilowatt-hour. This reduced price will be available 24 hours per day, seven days a week to all time-of-use customers, who make up the majority of electricity consumers in the province. By switching to a fixed off-peak rate, time-of-use customers will see rate reductions of over 50 per cent compared to on-peak rates.</p></blockquote>
<p>&#8220;During this unprecedented time, we are providing much-needed relief to Ontarians, specifically helping those who are doing the right thing by staying home and small businesses that have closed or are seeing fewer customers,&#8221; said Premier Doug Ford.</p>
<p>The electricity regulator in Ontario, the Ontario Energy Board, has also ordered the utility not to disconnect any residential or small business customers before July 31 of this year if they are late with their bill payments.</p>
<p>Gifford’s Affordable Energy Coalition has a conference call scheduled this week to discuss if more relief could or should be available to Nova Scotians who are staying home and running up the power bill. (We pay closer to 16 cents per kilowatt hour compared to the 10 cents Ontarians are paying).</p>
<p>Nova Scotia Power also announced it is donating an additional $500,000 to the Home Energy Assistance Top-up (HEAT Fund) available through the Salvation Army and Government of Nova Scotia to homeowners struggling with heating costs. Deadlines and eligibility restrictions have been waived for this year. Find out more <a href="http://nspower.ca/heatfund" target="_blank" rel="noopener noreferrer">here</a>.</p>
<p>The monopoly is also contributing $500,000 to the United Way’s Atlantic Compassion Fund to help people affected by the pandemic.</p>
<p>The news release says the company has suspended “non-essential in-home and in-business services, but critical service connects and disconnects will continue. Vegetation management will also continue to keep trees clear from critical customers and infrastructure across the province.”</p>
<p>Business but not business as usual.</p>
<hr />
<p>The Halifax Examiner is an advertising-free, subscriber-supported news site. Your subscription makes this work possible; <a href="https://www.halifaxexaminer.ca/subscription-account/subscription-levels/" target="_blank" rel="noopener noreferrer">please subscribe</a>.</p>
<!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/"
    dc:identifier="https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/"
    dc:title="Nova Scotia Power won&#8217;t cut off your electricity, but we&#8217;re not seeing the big cuts in rates that Ontario is ordering"
    trackback:ping="https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/trackback/" />
</rdf:RDF>-->
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.halifaxexaminer.ca/category/featured/" rel="category tag">Featured</a>, <a href="https://www.halifaxexaminer.ca/category/news/" rel="category tag">News</a>, <a href="https://www.halifaxexaminer.ca/category/province-house/" rel="category tag">Province House</a></span> </p></footer></article>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://www.halifaxexaminer.ca/login/?redirect_to=https%3A%2F%2Fwww.halifaxexaminer.ca%2Fprovince-house%2Fnova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="text-8" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">The Wrongful Conviction of Glen Assoun</h4>
			<div class="textwidget"><p><a class="alignleft" ><img src="https://www.halifaxexaminer.ca/wp-content/uploads/2019/07/Screen-Shot-2019-07-02-at-2.19.51-PM.png"/></a></p>
<p>In 1995, Brenda Way was brutally murdered behind a Dartmouth apartment building. In 1999, Glen Assoun was found guilty of the murder. He served 17 years in prison, but steadfastly maintained his innocence. In 2019, Glen Assoun was fully exonerated. </p>
<p><a href="https://www.halifaxexaminer.ca/investigation/the-glen-assoun-wrongful-conviction/">Click here to read the Halifax Examiner's extensive reporting on the case.</a></p>
</div>
		</div></section>
<section id="text-7" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">DEAD WRONG</h4>
			<div class="textwidget"><p><a class="alignleft" ><img src="https://www.halifaxexaminer.ca/wp-content/uploads/2016/03/1-47.jpg"/></a></p>
<p>A botched police investigation and a police coverup shed light on the murders of dozens of women in Nova Scotia. </p>
<p><a href="https://www.halifaxexaminer.ca/featured/dead-wrong-collector-page/">Click here to go to the DEAD WRONG home page</a>.</p>
</div>
		</div></section>
<section id="text-2" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">About the Halifax Examiner</h4>
			<div class="textwidget"><a class="alignleft" ><img src="https://www.halifaxexaminer.ca/wp-content/uploads/2019/02/Group-pic.jpg
" alt="Examiner folk"/></a>

The Halifax Examiner was founded by investigative reporter Tim Bousquet, and now includes a growing collection of writers, contributors, and staff. Left to right: Joan Baxter, Stephen Kimber, Linda Pannozzo, Erica Butler, Jennifer Henderson, Iris the Amazing, Tim Bousquet, Evelyn C. White, El Jones, Philip Moscovitch <a href=" https://www.halifaxexaminer.ca/about/">More about the Examiner</a>.</div>
		</div></section>
<section id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Sign up for email notification</h4>
<script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.7.5 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-10265 mc4wp-form-basic" method="post" data-id="10265" data-name="Default sign-up form" ><div class="mc4wp-form-fields"><p>Sign up to receive email notification of new posts on the Halifax Examiner. Note: signing up for email notification of new posts is NOT subscribing to the Halifax Examiner. To subscribe, <a href="https://www.halifaxexaminer.ca/subscription-account/subscription-levels/">click here</a>.</p>
<p>
    <label>First Name:</label>
    <input type="text" name="FNAME" placeholder="Your first name" required="required">
</p><p>
    <label>Last Name:</label>
    <input type="text" name="LNAME" placeholder="Your last name" required="required">
</p><p>
    <label>Email Address:</label>
    <input type="email" name="EMAIL" placeholder="Your email address" required="required">
</p>
<p>
    <input type="submit" value="Sign up!">
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1585136335" /><input type="hidden" name="_mc4wp_form_id" value="10265" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent posts</h4>
		<ul>
											<li>
					<a href="https://www.halifaxexaminer.ca/province-house/nova-scotia-power-wont-cut-off-your-electricity-but-were-not-seeing-the-big-cuts-in-rates-that-ontario-is-ordering/" aria-current="page">Nova Scotia Power won&#8217;t cut off your electricity, but we&#8217;re not seeing the big cuts in rates that Ontario is ordering</a>
											<span class="post-date">March 25, 2020</span>
									</li>
											<li>
					<a href="https://www.halifaxexaminer.ca/featured/false-information-in-the-time-of-corona/">False information in the time of corona</a>
											<span class="post-date">March 24, 2020</span>
									</li>
											<li>
					<a href="https://www.halifaxexaminer.ca/province-house/virtual-doctors-visits-now-ok-physicians-and-province-strike-deal/">Virtual doctors&#8217; visits now OK: physicians and province strike deal</a>
											<span class="post-date">March 24, 2020</span>
									</li>
											<li>
					<a href="https://www.halifaxexaminer.ca/city-hall/someone-called-the-cops-on-a-halifax-family-in-a-misguided-attempt-to-enforce-self-isolation/">Someone called the cops on a Halifax family in a misguided attempt to enforce self-isolation</a>
											<span class="post-date">March 24, 2020</span>
									</li>
											<li>
					<a href="https://www.halifaxexaminer.ca/province-house/clearing-out-the-jails/">Clearing out the jails</a>
											<span class="post-date">March 24, 2020</span>
									</li>
					</ul>
		</div></section>
</aside></div></div></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="text-6" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Commenting policy</h4>
			<div class="textwidget">All comments on the Halifax Examiner are subject to our commenting policy. You can view our commenting policy <a href=https://www.halifaxexaminer.ca/about/commenting-policy/> here</a>.
</div>
		</div></section>
</div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2020 </p></div></footer>		<!-- Memberships powered by Paid Memberships Pro v2.2.6.
 -->
	<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>
<script>

jQuery(function () {
    jQuery(".entry-content h2,.entry-content h3").each(function () {
        var hash = jQuery(this).html();
        if ( jQuery( "a[name='"+hash+"']" ).length == 0) {
			jQuery(this).before( "<a name='"+hash+"'>" );
		}
    });
});

</script>

<link rel="stylesheet" href="https://www.halifaxexaminer.ca/wp-content/cache/minify/1c0c2.css" media="all" />

<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									
									
									
									
								}
								.ssba img
								{
									width: 32px !important;
									padding: 4px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 4px;
								line-height: 27px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 14px;
									color: #adadad!important;
									font-weight: light;
								}
								

			   #ssba-bar-2 .ssbp-bar-list {
					max-width: 48px!important;;
			   }
			   #ssba-bar-2 .ssbp-bar-list li a {height: 48px!important; width: 48px!important; 
				}
				#ssba-bar-2 .ssbp-bar-list li a:hover {
				}
					
				#ssba-bar-2 .ssbp-bar-list li a::before {line-height: 48px!important;; font-size: 18px;}
				#ssba-bar-2 .ssbp-bar-list li a:hover::before {}
				#ssba-bar-2 .ssbp-bar-list li {
				margin: 0px 0!important;
				}@media only screen and ( max-width: 750px ) {
				#ssba-bar-2 {
				display: block;
				}
			}
@font-face {
				font-family: 'ssbp';
				src:url('https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('https://www.halifaxexaminer.ca/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
<script src="https://www.halifaxexaminer.ca/wp-content/cache/minify/072ef.js"></script>

<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var themeMyLogin = {"action":"","errors":[]};
/* ]]> */
</script>
<script src="https://www.halifaxexaminer.ca/wp-content/cache/minify/d7281.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.halifaxexaminer.ca\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>



<script src="https://www.halifaxexaminer.ca/wp-content/cache/minify/3324d.js"></script>

</body></html>


<style>
.long-form .entry-header {
    background-image: url('https://www.halifaxexaminer.ca/wp-content/uploads/2018/04/1-1.png');
</style>



<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 
Minified using disk
Database Caching 53/98 queries in 0.075 seconds using disk

Served from: www.halifaxexaminer.ca @ 2020-03-25 08:38:55 by W3 Total Cache
-->